您的位置:首页 > 运维架构

hdu 4405 Aeroplane chess(概率dp)

2016-08-02 22:24 357 查看


Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3347    Accepted Submission(s): 2122


Problem Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is
at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is
no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

 

Input

There are multiple test cases. 

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  

The input end with N=0, M=0. 

 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

 

Sample Input

2 0
8 3
2 4
4 5
7 8
0 0

 

Sample Output

1.1667
2.3441

 

Source

2012 ACM/ICPC Asia Regional Jinhua Online

题解:

一开始总想着把状态定义为d[i]表示从起点到点i的期望步数,想了好久发现做不了,后来看来题解才知道把d[i]定义为到目标状态的期望步数,从后往前更新,先处理能够直接相连的,再递推步数期望,这样做法就很简单了。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=100000+10;
vector<int> G[maxn];
int vis[maxn];
double d[maxn];
void init()
{
memset(d,0,sizeof(d));
memset(vis,false,sizeof(vis));
for(int i=0;i<maxn;i++) G[i].clear();
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0) break;
init();
while(m--)
{
int u,v;
scanf("%d%d",&u,&v);
G[v].push_back(u);
}
for(int i=0;i<G
.size();i++)
{
int v=G
[i];
vis[v]=true;
d[v]=0;
}
vis
=true;
for(int i=n-1;i>=0;i--)
{
if(!vis[i])
{
for(int j=i+1;j<=i+6;j++)
d[i]+=d[j]/6;
d[i]+=1;
vis[i]=true;
}
for(int j=0;j<G[i].size();j++)
{
int v=G[i][j];
d[v]=d[i];
vis[v]=true;
}
}
printf("%.4lf\n",d[0]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: