您的位置:首页 > 其它

POJ 3661 Running(区间DP)

2016-08-02 22:20 423 查看
Running

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion
factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches
0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.

 

Sample Input
5 2
5
3
4
2
10

Sample Output
9

题目大意:Bessie想成为一名运动牛,它每分钟跑的距离为Di,初始时疲劳度为0,每跑一分钟它就增加1疲劳度,但是它的疲劳度不能超过M。当它选择休息时,它的疲劳度每分钟减少1,但是它必须休息到疲劳度为0时才能继续跑。当N分钟过去后,它的疲劳度必须为0,否则它就没有足够的能量维持生活。求Bessie能跑的最远距离。
解题思路:定义dp[i][j]为第i分钟疲劳度为j时能够跑的最远距离,若第i分钟疲劳度j不为0,说明上一分钟在跑步,所以dp[[i][j] = dp[i  - 1][j - 1] + d[i];若第i分钟疲劳度为0,那么上一分钟疲劳度可能也为0,或者歇息了j分钟,由此可得以下状态转移方程:

dp[i][0] = max(dp[i - 1][0],dp[i - j][j])

dp[i][j] = dp[i - 1][j - 1] + d[i]

代码如下:

#include <cstdio>
#include <climits>
#include <algorithm>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn = 10005;
int dp[maxn][505],d[maxn];

int main()
{
int n,m;
scanf("%d %d",&n,&m);

for(int i = 1;i <= n;i++){
scanf("%d",&d[i]);
}
memset(dp,0,sizeof(dp));
for(int i = 1;i <= n;i++){
dp[i][0] = dp[i - 1][0];
for(int j = 1;j <= m;j++){
if(j < i ){
dp[i][0] = max(dp[i][0],dp[i - j][j]);
}
dp[i][j] = dp[i - 1][j - 1] + d[i];
}
}
printf("%d\n",dp
[0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ