您的位置:首页 > 编程语言 > C语言/C++

HDU 2056 矩形重叠面积

2016-08-02 20:37 330 查看

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 20855    Accepted Submission(s): 6775


[align=left]Problem Description[/align]
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

[align=left]Input[/align]
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the
other two points on the second rectangle are (x3,y3),(x4,y4).
 

[align=left]Output[/align]
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

[align=left]Sample Input[/align]

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

 

[align=left]Sample Output[/align]

1.00
56.25

 

[align=left]Author[/align]
seeyou
 

[align=left]Source[/align]
校庆杯Warm Up 

http://acm.hdu.edu.cn/showproblem.php?pid=2056

//几何 模板吧

原理  http://blog.sina.com.cn/s/blog_ab20767501017n1x.html

#include<stdio.h>
double max(double a,double b)
{
if(a>b)
return a;
else
return b;
}
double min(double a,double b)
{
if(a<b)
return a;
else
return b;
}
int main()
{
double x1,y1,x2,y2,x3,y3,x4,y4,t;
while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3,&x4,&y4)!=EOF)
{
if (x1>x2) t=x1,x1=x2,x2=t;
if (y1>y2) t=y1,y1=y2,y2=t;
if (x3>x4) t=x3,x3=x4,x4=t;
if (y3>y4) t=y3,y3=y4,y4=t;
x1=max(x1,x3);
y1=max(y1,y3);
x2=min(x2,x4);
y2=min(y2,y4);
printf("%.2lf\n",x1>x2||y1>y2?0:(x2-x1)*(y2-y1));
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 C++ 几何