您的位置:首页 > 其它

hdu-1969-Pie

2016-08-02 20:01 274 查看
二分题
点击打开链接看原题

[align=left]Problem Description[/align] My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
 
[align=left]Input[/align] One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

[align=left]Output[/align] For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3). 
[align=left]Sample Input[/align]
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

代码
#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <string>
#include <queue>
#include <vector>
#include <stack>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define MAXN 10005
#define esp 1.0e-5

int ro[MAXN];
double a[MAXN];
int n,f;
bool check(double mid)
{
int num=0,i;
for (i=0;i<n;i++)
{
num+=int(a[i]/mid);//关键
if(num>=f+1)
return true;
}
return false;
}
int main ()
{
int T;
scanf ("%d",&T);
while (T--)
{
scanf ("%d%d",&n,&f);
double sum=0;
for (int i=0;i<n;i++)
{
scanf ("%d",&ro[i]);
a[i]=ro[i]*ro[i]*PI;
sum+=a[i];
}
double r=sum/(f+1);
double l=0;
double mid;
while (r-l>esp)
{
mid=(r+l)*1.0/2;
if(check(mid))
l=mid;
else
r=mid;
}
printf ("%.4lf\n",l);
}
return 0;
}


这道题我开始也是一直在想该怎么去分,一直在想找出具体的办法去分,但是后来一想只是一道二分训练题啊,关键就在一次去将每个蛋糕都除以mid的面积,如果得到的值的和多于人的总数,那么也就是说,可以分配,当然这里需要强制装换数据类型。然后再缩小区间找最大的。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: