您的位置:首页 > 其它

poj 1383 Labyrinth(树的直径)

2016-08-02 19:18 375 查看
Labyrinth

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 4239 Accepted: 1592
Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have
found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means
also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow,
each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks
are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output
Maximum rope length is 0.
Maximum rope length is 8.

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<algorithm>
#define maxn 1010
using namespace std;
struct node{
int x;
int y;
int step;
};
int dx[4] = {1,0,-1,0};
int dy[4] = {0,1,0,-1};
char map[maxn][maxn];
bool vis[maxn][maxn];
int a,b,n,m,ans;
void bfs(int xx,int yy)
{
memset(vis,false,sizeof(vis));
node now,next;
queue<node > q;
ans = 0;
now.x = xx;
now.y = yy;
now.step = 0;
vis[now.x][now.y] = true;
q.push(now);
while(!q.empty())
{
next = q.front();
q.pop();
for(int i = 0 ; i < 4 ; i++)
{
now.x = next.x + dx[i];
now.y = next.y + dy[i];
if(now.x >= 0 && now.x < m && now.y >= 0 && now.y < n && !vis[now.x][now.y] && map[now.x][now.y] != '#')
{
vis[now.x][now.y] = true;
now.step = next.step + 1;
if(ans < now.step)
{
ans = now.step;
a = now.x;
b = now.y;
}
q.push(now);
}
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int sx = 0,sy = 0;
int falg = 0;
sizeof(map,'\0',sizeof(map));
scanf("%d%d",&n,&m);
for(int i = 0; i < m ; i++)
scanf("%s",map[i]);
for(int i = 0 ; i < n ; i++){
for(int j = 0 ; j < m ; j++)
{
if(map[i][j] == '.')
{
sx = i;
sy = j;
falg = 1;
break;
}
}
if(falg)
break;
}
bfs(sx,sy);
bfs(a,b);
printf("Maximum rope length is %d.\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: