您的位置:首页 > 大数据 > 人工智能

A + B for you again

2016-08-02 17:15 309 查看
A + B for you again

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6276 Accepted Submission(s): 1551

Problem Description

Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.

Input

For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.

Output

Print the ultimate string by the book.

Sample Input

asdf sdfg

asdf ghjk

Sample Output

asdfg

asdfghjk

Author

Wang Ye

给两串字符,输出最长合串(除去相同串)

列:asd asasd

输出 asasd

#include <iostream>
#include <cstdio>
#include <cstring>
#define N 100010
using namespace std;
int next[100005];
void getnext(char *t)
{
int i=1,j=0;next[1]=0;
int len=strlen(t+1);
while(i<len)
{
if(j==0 || t[i]==t[j])
{
++i;++j;next[i]=j;
}
else
j=next[j];
}
}
int kmp(char *s,char *t)
{
int i,j,len1,len2;
getnext(t);
i=1;j=1;
len1=strlen(s+1);len2=strlen(t+1);
while(i<=len1 && j<=len2)
{
if(j==0 || s[i]==t[j])
{
++i;++j;
}
else
{
j=next[j];
}
}
if(j>len2 && i<=len1)
return 0;
return j-1;//求出连续相同的串的长度
}
char str1[100005],str2[100005];
int main()
{
int mark1,mark2,j;
while(scanf("%s%s",str1+1,str2+1)!=EOF)
{
mark1=kmp(str1,str2);
mark2=kmp(str2,str1);
if(mark1 == mark2)
{
if(strcmp(str1+1,str2+1)>=0)
{
printf("%s",str2+1);
for(j=mark1+1;str1[j]!='\0';j++)
printf("%c",str1[j]);
}
else
{
printf("%s",str1+1);
for(j=mark2+1;str2[j]!='\0';j++)
printf("%c",str2[j]);
}
}
else if(mark1>mark2)
{
printf("%s",str1+1);
for(j=mark1+1;str2[j]!='\0';j++)
printf("%c",str2[j]);
}
else if(mark2>mark1)
{
printf("%s",str2+1);
for(j=mark2+1;str1[j]!='\0';j++)
printf("%c",str1[j]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: