您的位置:首页 > 其它

【POJ】-2631-Roads in the North(树的直径)

2016-08-02 16:36 387 查看
Roads in the North

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2563 Accepted: 1263
Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 

Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output

You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input
5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output
22


这是从大神博客截的图,关于树的直径的证明,也定好理解的。用两次BFS就好



#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define MAX 10000
vector<int> link[MAX+10]; //记录连接
vector<int> va[MAX+10]; //记录连接的点间的权值
bool vis[MAX+10]; //是否被访问
int dis[MAX+10]; //到当前点的距离
void init()
{
for(int i=0;i<=MAX;i++)
{
link[i].clear();
va[i].clear(); //初始化
}
}
int bfs(int x)
{
int ans; //最远的点
int maxx=0; //距离
memset(vis,false,sizeof(vis));
memset(dis,0,sizeof(dis));
queue<int> q;
dis[x]=0;
q.push(x);
vis[x]=true;
while(!q.empty())
{
int st=q.front();
q.pop();
for(int i=0;i<link[st].size();i++)
{
if(!vis[link[st][i]]) //没有被访问
{
q.push(link[st][i]);
dis[link[st][i]]=dis[st]+va[st][i]; //到当前点的距离等于到父节点的距离加父节点到他的距离
if(maxx<dis[link[st][i]])
{
maxx=dis[link[st][i]]; //更新最大距离
ans=link[st][i];
}
vis[link[st][i]]=true; //标记
}
}
}
return ans;
}
int main()
{
int t1,t2,t3;
init();
int n=0;
while(scanf("%d %d %d",&t1,&t2,&t3)!=EOF) //输入 Ctrl+z 结束输入
{
link[t1].push_back(t2);
va[t1].push_back(t3);
link[t2].push_back(t1); //一定要双向存图
va[t2].push_back(t3);
n=max(n,max(t1,t2));
}
if(n==0)
{
printf("0\n");
return 0;
}
int t=bfs(1); //从任意一个节点开始
int ans=bfs(t);
printf("%d\n",dis[ans]);
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: