您的位置:首页 > 其它

POJ 1985 Cow Marathon (树的直径)

2016-08-02 14:57 253 查看
Cow Marathon

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 4895 Accepted: 2386
Case Time Limit: 1000MS
Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence
of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms).
Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".
Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input
7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output
52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source

USACO 2004 February

题意:求最长路,模板题

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define MAX 400010
using namespace std;
int edgesum=0;
int head[MAX*2];
int ans;
int T;
int dis[MAX*2];
bool vis[MAX*2];
struct node
{
int from,to,val,next;
}edge[MAX*2];
void add(int u,int v,int w)
{
edge[edgesum].from=u;
edge[edgesum].to=v;
edge[edgesum].val=w;
edge[edgesum].next=head[u];
head[u]=edgesum++;
}
void BFS(int s)
{
int i;
queue<int>Q;
memset(dis,0,sizeof(dis));
memset(vis,false,sizeof(vis));
vis[s]=true;
dis[s]=0;
Q.push(s);
ans=0;
while(!Q.empty())
{
int u=Q.front();
Q.pop();
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].to;
if(!vis[v])
{
if(dis[v]<dis[u]+edge[i].val)
{
dis[v]=dis[u]+edge[i].val;
if(ans<dis[v])
{
ans=dis[v];
T=v;
}
}
vis[v]=true;
Q.push(v);
}
}
}
}
int main()
{
int u,v,w,n,m;
char str[5];
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(head,-1,sizeof(head));
while(m--)
{
scanf("%d%d%d%s",&u,&v,&w,&str);
add(u,v,w);
add(v,u,w);
}
BFS(1);
BFS(T);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: