您的位置:首页 > 其它

POJ1861 Network(Kruskal)(并查集)

2016-08-02 12:20 375 查看
Network

Time Limit: 1000MS

Memory Limit: 30000K
Total Submissions: 16047Accepted: 6362Special Judge
Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are
cheaper, it is necessary to make such a plan of hub connection, that the
maximum length of a single cable is minimal. There is another problem —
not each hub can be connected to any other one because of compatibility
problems and building geometry limitations. Of course, Andrew will
provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The
first line of the input contains two integer numbers: N - the number of
hubs in the network (2 <= N <= 1000) and M - the number of
possible hub connections (1 <= M <= 15000). All hubs are numbered
from 1 to N. The following M lines contain information about possible
connections - the numbers of two hubs, which can be connected and the
cable length required to connect them. Length is a positive integer
number that does not exceed 106. There will be no more than
one way to connect two hubs. A hub cannot be connected to itself. There
will always be at least one way to connect all hubs.
Output

Output
first the maximum length of a single cable in your hub connection plan
(the value you should minimize). Then output your plan: first output P -
the number of cables used, then output P pairs of integer numbers -
numbers of hubs connected by the corresponding cable. Separate numbers
by spaces and/or line breaks.
Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4
【分析】首先,这一题有问题。第一,输入文件包含多个测试用据,他没说;第二,测试用例的结果错了,应该是
1
3
1 2
1 3
3 4
而且应该是多判的,可以用Kruskal;


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#include<functional>
#define mod 1000000007
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
using namespace std;
typedef long long ll;
const int N=1005;
const int M=15005;
vector<int>q;
struct Edg {
int v,u;
int w;
} edg[M];
bool cmp(Edg g,Edg h) {
return g.w<h.w;
}
int n,m,k,maxn;
int parent
;
void init() {
for(int i=0; i<n; i++)parent[i]=i;
}
void Build() {
int u,v,w;
for(int i=0; i<m; i++) {
scanf("%d%d%d",&u,&v,&w);
edg[i].u=u;
edg[i].v=v;
edg[i].w=w;
}
sort(edg,edg+m,cmp);
}
int Find(int x) {
if(parent[x] != x) parent[x] = Find(parent[x]);
return parent[x];
}//查找并返回节点x所属集合的根节点
void Union(int x,int y) {
x = Find(x);
y = Find(y);
if(x == y) return;
parent[y] = x;
}//将两个不同集合的元素进行合并
void Kruskal() {
int sum=0;
int num=0;
int u,v;
for(int i=0; i<m; i++) {
u=edg[i].u;
v=edg[i].v;
if(Find(u)!=Find(v)) {
sum+=edg[i].w;
maxn=max(maxn,edg[i].w);
q.push_back(i);
num++;
Union(u,v);
}
if(num>=n-1) {
printf("%d\n%d\n",maxn,n-1);

break;
}
}
}
int main() {
while(~scanf("%d%d",&n,&m)) {
while(!q.empty())q.pop_back();
maxn=-1;
init();
Build();
Kruskal();
for(int i=0; i<q.size(); i++) {
int l=q[i];
printf("%d %d\n",edg[l].u,edg[l].v);
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: