您的位置:首页 > 其它

HDU1213How Many Tables 并查集路径压缩

2016-08-02 11:18 309 查看
[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

题意:t组数据,n个人,找相互认识的人拼成一桌,求一共几桌

思路:并查集典型,需要的圆桌的个数=根节点的个数  路径优化一下

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<functional>
#include<map>
using namespace std;

int father[1005];//储存i的father父节点
int t;
int ans;
void makeSet() {
for (int i = 0; i < 1005; i++) father[i] = i;
}
int Find(int x) {//路径压缩 迭代 最优版
int root = x; //根节点
while (root != father[root]) { //寻找根节点
root = father[root];
}
while (x != root) {
int tmp = father[x];
father[x] = root; //根节点赋值
x = tmp;
}
return root;
}

void Union(int x, int y) {
int a;
int b;
a = Find(x);
b = Find(y);
father[b] = a;
}

int main()
{
cin >> t;
while (t--) {
int a, b;
int n, m;
makeSet();
ans = 0;
scanf("%d %d", &n, &m);
for (int i = 1; i <= m; i++) {
scanf("%d %d", &a, &b);
Union(a, b);
}
for (int i = 1; i <= n; i++) {
if (i == father[i]) ans++;
}
cout << ans << endl;
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm hdu 并查集