您的位置:首页 > 产品设计 > UI/UE

UVa 133 - The Dole Queue

2016-08-02 09:46 381 查看

The Dole Queue

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3

0 0 0

Sample output

~~4~~8,~~9~~5,~~3~~1,~~2~~6, ~~10,~~7

~~ represents a space.

一个小破题目,烦死我了,一开始自己写没有考虑重复出现的字母

写的自己都恶心的代码,顺着思路来的,随便看看就好

书上用函数,看不懂,懒得看

遍历循环找到输出结果,然后用0取代

AC

#include <cstdio>
#define maxn 25
int a[maxn];

int main()
{
int n,k,m;
while(scanf("%d%d%d",&n,&k,&m))
{
if(n==0&&k==0&&m==0)
break;
for(int i=1; i<=n; i++)
a[i]=i;
int left=n;
int wow=0,xox=n+1;
while(left)
{
int cnt=1;//计数,K次输出一个数
int flag=1;//flag输出一个数
int x,y;
int i=0,j=0;
for(i=wow+1; cnt<=k; i++)//每次都是输出的下一个开始
{
if(i==n+1)
i=1;
if(cnt==k)
{
x=a[i];
wow=i;//将输出的数位置进行标记
}
if(a[i]!=0)
cnt++;
}
for(j=xox-1; flag<=m; j--)
{
if(j==-1)
j=n;

if(flag==m)
{
y=a[j];
xox=j;
}
if(a[j]!=0)
flag++;
}
a[wow]=0;
a[xox]=0;
if(x==y)
{
printf("%3d",x);
left-=1;
}
else
{
printf("%3d%3d",x,y);
left-=2;
}
if(left)
printf(",");
else
printf("\n");
}
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva