您的位置:首页 > 其它

Poj 2955 Brackets【区间dp】

2016-08-02 09:45 288 查看
Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6105 Accepted: 3269
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1,i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))

()()()

([]])

)[)(

([][][)

end

Sample Output
6
6
4
0
6
Source

Stanford Local 2004

题目大意:求给出的字符串的最长匹配。

思路:

1、设定dp【i】【j】表示从i到j这个区间内字符串的最长匹配。

2、那么不难理解:dp【i】【j】=dp【i+1】【j-1】+2(if(j>i&&i位子上的字符和j位子上的字符能够匹配上。))

3、如果有这样的字符串:()(),其中明显有dp【1】【2】=2,dp【3】【4】=2;dp【1】【4】=2,因为两个匹配是可以合并的,如:dp【1】【4】=dp【1】【2】+dp【3】【4】=4所以还有:

dp【i】【j】=max(dp【i】【j】,dp【i】【k】+dp【k+1】【j】);

Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int dp[150][150];
int main()
{
char a[150];
while(~scanf("%s",a))
{
memset(dp,0,sizeof(dp));
if(strcmp(a,"end")==0)
{
break;
}
int n=strlen(a);
for(int d=1;d<n;d++)
{
for(int i=0;i+d<n;i++)
{
int j=i+d;
if(a[j]==')'&&a[i]=='('||a[j]==']'&&a[i]=='[')
{
dp[i][j]=dp[i+1][j-1]+2;
}
for(int k=0;k<n;k++)
{
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
}
}
}
printf("%d\n",dp[0][n-1]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Poj 2955 pku 2955