您的位置:首页 > 其它

A - Ice_cream's world I

2016-08-02 09:04 218 查看
A - Ice_cream's world I
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 

One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7


Sample Output

3


利用并查集,围成一个环加一

/*************************************************************************
> File Name: ice_creamworld.cpp
> Author:chudongfang
> Mail:1149669942@qq.com
> Created Time: 2016年08月02日 星期二 08时22分42秒
************************************************************************/

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
int parent[1005];

int find_set(int x);

int main(int argc,char *argv[])
{
int n,m,i,j,x,y,x1,y1;

while(scanf("%d %d",&n,&m) != EOF)
{
int flag=0;
for(i=0;i<n;i++)
parent[i]=i;
for(i=0;i<m;i++)
{
scanf("%d %d",&x,&y);
x1 = find_set(x);
y1 = find_set(y);
if(x1 != y1)
parent[x1] = y1;
else
flag++;
}

printf("%d\n",flag);
}

return 0;
}

int find_set(int x){
if(parent[x] != x){
parent[x] = find_set(parent[x]);
}
return parent[x];
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: