您的位置:首页 > 其它

Ice_cream's world I<hdoj2120>

2016-08-02 08:48 197 查看
Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world.
But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

 

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

 

Output

Output the maximum number of ACMers who will be awarded.

One answer one line.

 

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

Sample Output

3

 
       很简单的题     查找环的个数

#include<stdio.h>
#include<cstring>
int pre[1001];
int find(int p)  //路径压缩
{
int r=p;
int t;
while(p!=pre[p])
p=pre[p];
while(r!=p)
{
t=pre[r];
pre[r]=p;
r=t;
}
return p;
}
void merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
{
pre[fx]=fy;
}
}
int main()
{
int m,n,a,b,i,flog,k,f;
while(scanf("%d%d",&a,&b)!=EOF)
{
for(int i=0;i<a;i++)
{
pre[i]=i;
}
flog=0;
while(b--)
{
scanf("%d%d",&n,&m);
if(find(n)==find(m))//判断是否成环
flog++;
merge(n,m);
}
printf("%d\n",flog);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: