您的位置:首页 > 其它

hdoj 5326 Work【并查集】

2016-08-01 21:14 393 查看

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1711    Accepted Submission(s): 1027


[align=left]Problem Description[/align]



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.

As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.

Now, give you the relation of a company, can you calculate how many people manage k people.

 

[align=left]Input[/align]
There are multiple test cases.

Each test case begins with two integers n and k, n indicates the number of stuff of the company.

Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n

1 <= A, B <= n

 

[align=left]Output[/align]
For each test case, output the answer as described above.
 

[align=left]Sample Input[/align]

7 2
1 2
1 3
2 4
2 5
3 6
3 7

 

[align=left]Sample Output[/align]

2

 

代码:

#include<cstdio>
int per[110],num[110];//记录下属的个数
void find(int x)
{
if(per[x]!=x)
{
num[per[x]]++; //这里主要是运用了查找时候的递归因素,逐个往上递归找根结点的时候,把每个上级所带领的下属个数都加1
find(per[x]);
return ;
}
}
int main()
{
int n,k;
while(~scanf("%d%d",&n,&k))
{
for(int i=1;i<=n;i++)
{
per[i]=i;
num[i]=0;
}
for(int i=1;i<n;i++)
{
int a,b;
scanf("%d%d",&a,&b);
if(a!=b)
per[b]=a;
}
for(int i=1;i<=n;i++)//寻找每个点的下属的个数
find(i);
int ans=0;
for(int i=1;i<=n;i++)
{
if(num[i]==k)
ans++;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: