您的位置:首页 > 其它

HDU:1325 Is It A Tree?(并查集+有向图树的判断)

2016-08-01 21:12 423 查看


Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21711 Accepted Submission(s): 4901



Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


Source

North Central North America 1997

Recommend

Ignatius.L

题目大意:给你一些连接的有向节点信息,问组成的图是否成一棵树。

解题思路:1.判断是否成环(应不成环);2.判断每个节点入度度数(每个节点的入度度数应该小于等于1);3.判断树的个数(成一棵树)。4.注意0 0空树也是树.

代码如下:

#include <cstdio>
#include <cstring>
int in[1010];
int pre[1010];
int find(int x)
{
int r=x;
while(r!=pre[r])
{
r=pre[r];
}
int i=x,j;
while(i!=r)//压缩优化下
{
j=pre[i];
pre[i]=r;
i=j;
}
return r;
}
int main()
{
int x,y;
int hao=1;
while(scanf("%d%d",&x,&y)!=EOF)
{
if(x<0&&y<0)
break;
if(x==0&&y==0)//空树也是树
{
printf("Case %d is a tree.\n",hao++);
continue;
}
memset(in,0,sizeof(in));//初始化
memset(pre,0,sizeof(pre));//初始化父节点 ,初始化为0方便后边树的个数的判断
if(pre[x]==0)
{
pre[x]=x;
}
if(pre[y]==0)
{
pre[y]=y;
}
int flaghuan=0;//成环标志
int fx=find(x);
int fy=find(y);
if(fx==fy)//新加的俩元素根相同,则一定成环
{
flaghuan=1;
}
pre[fy]=fx;
in[y]++;//儿子度数++;
while(scanf("%d%d",&x,&y)!=EOF)
{
if(x==0&&y==0)
break;
if(pre[x]==0)
{
pre[x]=x;
}
if(pre[y]==0)
{
pre[y]=y;
}
int fx=find(x);
int fy=find(y);
if(fx==fy)
{
flaghuan=1;
}
pre[fy]=fx;
in[y]++;//儿子度数++
}
if(flaghuan==1)//成环
{
printf("Case %d is not a tree.\n",hao++);
}
else
{
int cnt=0;
int rootnum=0;
int flagdu=0;
for(int i=1;i<1010;i++)//统计入度是否合格,树的个数
{
if(pre[i]==i)
rootnum++;
if(in[i]>1)
flagdu=1;
}
if(rootnum>1)//超过一棵树
{
printf("Case %d is not a tree.\n",hao++);
}
else
{
if(flagdu==1)//入度不合格
{
printf("Case %d is not a tree.\n",hao++);
}
else
{
printf("Case %d is a tree.\n",hao++);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集