您的位置:首页 > 其它

HDOJ-2120 Ice_cream's world I

2016-08-01 20:56 246 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1280    Accepted Submission(s): 765

[align=left]Problem Description[/align]
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

[align=left]Input[/align]
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.
 

[align=left]Output[/align]
Output the maximum number of ACMers who will be awarded.

One answer one line.
 

[align=left]Sample Input[/align]

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

[align=left]Sample Output[/align]

3

 

[align=left]Author[/align]
Wiskey
介个题就是利用并查集判断有几个环,在判断两个不相等的数的根节点相等时就是一个环。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#define M 10000+10
using namespace std;
int ans;
int fa[M];
void init()
{
for(int i=0;i<M;i++)
fa[i]=i;
}
int findroot(int x)
{
if(x!=fa[x])
fa[x]=findroot(fa[x]);
return fa[x];
}
void Union(int x,int y)
{
int nx=findroot(x);
int ny=findroot(y);
if(nx!=ny)
fa[ny]=nx;
else ans++;
}
int main()
{
int m,n;
while(~scanf("%d%d",&n,&m))
{
ans=0;
init();
int a,b;
for(int i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
Union(a,b);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: