您的位置:首页 > 其它

HDOJ 2120 Ice_cream's world I【判断环的个数】

2016-08-01 20:42 295 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1277 Accepted Submission(s): 763

[align=left]Problem Description[/align]
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers
be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem,
you will be get a land.

[align=left]Input[/align]
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain
two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

[align=left]Output[/align]
Output the maximum number of ACMers who will be awarded.

One answer one line.

[align=left]Sample Input[/align]

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7


[align=left]Sample Output[/align]

3
判断有几个环。。。代码:[code]#include<stdio.h>
#include<string.h>
int pre[1010];
int find(int x)
{
int r=x,j;
while(r!=pre[r])
{
r=pre[r];
}
while(x!=r)
{
j=pre[x];
pre[x]=r;
x=j;
}
return r;
}
int merge(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx==fy)
return 1;
pre[fx]=fy;
return 0;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int ans=0;
for(int i=0;i<n;i++)
{
pre[i]=i;
}
for(int i=1;i<=m;i++)
{
int u,v;
scanf("%d%d",&u,&v);
ans+=merge(u,v);
}
printf("%d\n",ans);
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: