您的位置:首页 > 其它

hdu 4707(Pet)

2016-08-01 20:39 260 查看
Pet  (并查集)

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2508    Accepted Submission(s): 1233


[align=left]Problem Description[/align]
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for
three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere
nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is
always one distance unit.
 

[align=left]Input[/align]
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space.
N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room
is always at location 0.

 

[align=left]Output[/align]
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

[align=left]Sample Input[/align]

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

 

[align=left]Sample Output[/align]

2

题意:问到0点距离大于2的点有几个

题解:查找根节点,每次更新到根节点的距离,不需要Union()函数。

代码:

#include<cstdio>
#define M 100100
using namespace std;
int n;
int fa[M];
int rank[M];
void init(){
for (int i=0;i<n;i++){
fa[i]=i;
rank[i]=0;//距离初始化
}
}
int find(int x){
if (x!=fa[x]){
rank[x]+=rank[fa[x]];//x点的距离等于自身加上父节点的距离
fa[x]=find(fa[x]);
}
return fa[x];
}
int main(){
int t,d;
int a,b;
int x,y;
int sum;
scanf ("%d",&t);
while (t--){
sum = 0;
scanf ("%d %d",&n,&d);
init();
for (int i=0;i<n-1;i++){
scanf ("%d %d",&a,&b);
x=find(a);
y=find(b);
rank[y]=1-rank[b]+rank[a];//自己没想到,模拟一下就行
fa[y]=x;
}
for (int i=0;i<n;i++)
find(i);
for (int i=0;i<n;i++){
if (rank[i]>d&&!find(i))//距离大于d并且根节点为0
sum++;
}
printf ("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: