您的位置:首页 > 其它

POJ 1905 Expanding Rods(二分)

2016-08-01 19:47 423 查看
Expanding Rods

Description


When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod
expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.
Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

题目大意:有一个直杆,它受到温度影响会发生弯曲,弯曲后的长度L' = (1 + n * C) * L,其中n是温度变化,C是温度的影响系数。现在将直杆放在两面距离为L的墙之间,温度变化后直杆发生弯曲,弯曲后长度为L',求直杆弯曲后的最高点与水平时的距离,直杆弯曲的高度不会超过直杆长度的一半。
解题思路:直杆弯曲后属于某个圆的一部分,设那个圆半径为R,圆心角的一半为θ,则L' = 2Rarcsin(L / 2R),根据勾股定理可得R ^ 2 = (L / 2) ^ 2 + (R - H) ^ 2,可以推出R = (4H ^ 2 + L ^ 2) / 8H,将R带入,可以得到一个L'与h的关系式,而L'可由输入求得,所以二分h即可。

代码如下:

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>

using namespace std;

const double PI = acos(-1.0);
const double EPS = 1e-8;

double L,n,C;

double cal(double h)
{
double r = (4 * h * h + L * L) / (8.0 * h);
return 2 * asin(L / (2 * r)) * r;
}

int main()
{
while(scanf("%lf %lf %lf",&L,&n,&C) && (L > 0 - EPS || n > 0 - EPS || C > 0 - EPS)){
double lb,ub,mid;
double l = (1 + n * C) * L;
lb = 0,ub = L / 2;
while(ub - lb > EPS){
mid = (lb + ub) / 2.0;
if(cal(mid) < l)
lb = mid;
else
ub = mid;
}
printf("%.3f\n",mid);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ