您的位置:首页 > 其它

hd 2010 Ice_cream's world I

2016-08-01 18:55 232 查看


Ice_cream's world I

                                                                 Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768
K (Java/Others)

                                                                                        Total Submission(s): 1252    Accepted Submission(s): 748


Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world.
But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

 

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

 

Output

Output the maximum number of ACMers who will be awarded.

One answer one line.

 

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

Sample Output

3
#include<cstdio>
#include<iostream>
using namespace std;
int pre[1010];
int falg;
int find(int x)
{
if(x != pre[x])
pre[x] = find(pre[x]);
return pre[x];
}
void Union(int x,int y)
{
int fx,fy;
fx = find(x);
fy = find(y);
if(fx != fy)
pre[fx] = fy;
else
falg++;
}
int main()
{
int n,m;
while(cin >> n >> m)
{
for(int i = 0 ; i < n ; i++)
pre[i] = i;
int a,b;
falg = 0;
while(m--)
{
cin >> a >> b;
Union(a,b);
}
cout << falg << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: