您的位置:首页 > 其它

【HDU】2669 - Romantic(扩展欧几里得)

2016-08-01 17:30 288 查看
点击打开题目


Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4998    Accepted Submission(s): 2078


Problem Description

The Sky is Sprite.

The Birds is Fly in the Sky.

The Wind is Wonderful.

Blew Throw the Trees

Trees are Shaking, Leaves are Falling.

Lovers Walk passing, and so are You. 

................................Write in English class by yifenfei


 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!

Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.

 

Input

The input contains multiple test cases.

Each case two nonnegative integer a,b (0<a, b<=2^31)

 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

 

Sample Input

77 51
10 44
34 79

 

Sample Output

2 -3
sorry
7 -3

 

Author

yifenfei

 

Source

HDU女生专场公开赛——谁说女子不如男

 

全裸的一道扩展欧几里得题。注意用 __int64 。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
__int64 exGCD(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if (!b)
{
x = 1;
y = 0;
return a;
}
__int64 g = exGCD(b,a%b,y,x);
y -= a / b * x;
return g;
}
int main()
{
__int64 a,b,c,d,x,y;
while (~scanf ("%I64d %I64d",&a,&b))
{
c = exGCD(a,b,x,y);
if (c != 1)
puts("sorry");
else
{
x = (x % b + b) % b;
printf ("%I64d %I64d\n",x,(1-a*x) / b);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: