您的位置:首页 > 其它

HDU 4707 Pet(BFS,统计树节点深度)

2016-08-01 16:35 591 查看

Pet(点击做题)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2472    Accepted Submission(s): 1208

[align=left]Problem Description[/align]
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for
three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere
nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is
always one distance unit.
 

[align=left]Input[/align]
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space.
N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room
is always at location 0.

 

[align=left]Output[/align]
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

[align=left]Sample Input[/align]

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

 

[align=left]Sample Output[/align]

2

 

[align=left]Source[/align]
2013 ACM/ICPC Asia Regional Online —— Warmup

 

题意:

就是仓鼠宠物丢了,需要去寻找,给定家附近的地址,每个地址间的距离都是单位距离,距离 > d 的时候有找到的可能性。

思路:

问题可化为在一棵树上找有多少个节点的深度 > d 就可以了。先前翻译失误,认为找的是 < d 的节点。

代码(参考):
#include<stdio.h>
#include<string.h>
#define MYDD 1103*128

int n,d,x,y,ans;
int b[MYDD];
struct node {
int to;//下一节点
int step;//节点所在的层数
int find;//寻找和该节点相关的其它路
} dd[MYDD];

void BFS(int x,int y) {
if(b[x]!=-1) {//遍历整棵树
for(int j=b[x]; j!=0; j=dd[j].find) {
dd[j].step=y;
if(dd[j].step>=d)
ans++;
BFS(dd[j].to,y+1);
}
}
}

int main() {
int t;
scanf("%d",&t);
while(t--) {
memset(b,0,sizeof(b));
scanf("%d%d",&n,&d);
for(int j=1; j<n; j++) {
scanf("%d%d",&x,&y);
dd[j].to=y;//下一节点
dd[j].find=b[x];//寻找和该节点相关的其它路
b[x]=j;
}
ans=0;
BFS(0,0);
printf("%d\n",ans);
}
return 0;
}

树的节点深度的学习。

***************************************************

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: