您的位置:首页 > 其它

【杭电】[2120]Ice_cream's world I

2016-08-01 16:31 197 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Problem Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7


Sample Output

3


其实也就是找出成环个数

已经在同一集合中的又进行合并

find(x)==find(y)

则形成一个环 res++

#include<stdio.h>
int par[1200];
int res;
int find(int m) {
if(m==par[m])
return m;
else
return par[m]=find(par[m]);
}
void unite(int x,int y) {
x=find(x);
y=find(y);
if(x==y)
res++;
else {
par[y]=x;
}
}
int main() {
int n,m;
while(scanf("%d %d",&n,&m)!=EOF) {
for(int i=0; i<n; i++) {
par[i]=i;
}
res=0;
while(m--) {
int a,b;
scanf("%d %d",&a,&b);
unite(a,b);
}
printf("%d\n",res);
}
return 0;
}


题目地址:【杭电】[2120]Ice_cream's world I

查看原文:http://www.boiltask.com/blog/?p=1978
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: