您的位置:首页 > 其它

hdu 1004 Let the Balloon Rise ( 字符串简单处理)

2016-08-01 16:23 218 查看

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 107103 Accepted Submission(s): 41514



Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0


Sample Output

red
pink


Author

WU, Jiazhi

Source

ZJCPC2004

Recommend

JGShining | We have carefully selected several similar problems for you: 1002 1005 1003 1009 1019

Statistic | Submit | Discuss | Note

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct In{
int s;
char a[20];
}c[1000];
int cmp(const void *a,const void *b){
struct In *c=(In *)a;
struct In *d=(In *)b;
if(c->s !=d->s) return d->s - c->s ;
}
int main(){
int i,j,n;
while(scanf("%d",&n)&&n){
for(i=0;i<n;i++)
scanf("%s",&c[i].a),c[i].s=1;
for(i=0;i<n;i++)
for(j=i+1;j<n;j++){
if(strcmp(c[i].a,c[j].a)==0)//运用strlen()
c[i].s=c[i].s+1;
}
qsort(c,n,sizeof(c[0]),cmp);
printf("%s\n",c[0].a);
}
return 0;
}


字符串比较时运用函数,不要直接用“==”比较
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: