您的位置:首页 > 其它

HDOJ 2120 Ice_cream's world I(并查集)

2016-08-01 15:28 429 查看
Ice_cream's world I
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u
Submit Status

Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and
B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 

One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7


Sample Output

3

并查集的应用,用来查找被分割的区域个数。即当两个节点值相同时说明已经为了一个圈,否则不可能,此时区域个数加1.#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int a[10001000],k;
int find(int x)
{
if( a[x]!= x )
a[x] = find(a[x]);
return a[x];
}
void mange(int x,int y)
{
int fx,fy;
fx=find(x);
fy=find(y);
if(fx!=fy)
a[fx]=fy;
else
k++;//节点值相同则存在环

}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<=n;i++)
{a[i]=i;}
k=0;
int K1,K2;
for(int i=1;i<=m;i++)
{
scanf("%d%d",&K1,&K2);
mange(K1,K2);
}

printf("%d\n",k);

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm