您的位置:首页 > 其它

HDU-1213-How Many Tables【并查集】

2016-08-01 15:28 295 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24324    Accepted Submission(s): 12169

[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

题意:认识的人坐一块;不认识的两人,认识同一个人也可以坐在一块

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,fa[10010];
int find(int x)
{
if(x==fa[x]) return x;
return fa[x]=find(fa[x]);
}
void Union(int x,int y)
{
int nx=find(x);
int ny=find(y);
if(nx!=ny)
{
fa[ny]=nx;
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
fa[i]=i;
}
int a,b;
while(m--)
{
scanf("%d %d",&a,&b);
Union(a,b);
}
int ans=0;
for(int i=1;i<=n;i++)
{
if(fa[i]==i)
{
ans++; // 一张桌子上必存在一个人满足 fa[i]=[i],所以要计算桌子个数,计算满足有几个 fa[i]=i 就行了
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: