您的位置:首页 > 其它

杭电-2120 Ice_cream's world I(无向图回路)

2016-08-01 15:20 232 查看

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1192    Accepted Submission(s): 715

[align=left]Problem Description[/align]
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 
[align=left]Input[/align]
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.
 
[align=left]Output[/align]
Output the maximum number of ACMers who will be awarded.

One answer one line.
 
[align=left]Sample Input[/align]

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 
[align=left]Sample Output[/align]

3

 
[align=left]Author[/align]
Wiskey
 
[align=left]Source[/align]
HDU 2007-10 Programming Contest_WarmUp
 
[align=left]Rcommend[/align]
威士忌   |   We have carefully selected several similar problems for you:  2122 2118 2119 2121 2117 

解题思路:
找构成回路的个数;
AC代码:
#include<stdio.h>
#include<string.h>
int set[11000];
int find(int p)
{
while(p!=set[p])
{
p=set[p];
}
return p;
}
void hebing(int x,int y)
{
int fx=find(x);
int fy=find(y);
if(fx!=fy)
set[fx]=fy;
}
int main()
{
int n,m;
int u,v,i;
while(scanf("%d%d",&n,&m)!=EOF)
{
int sum=0;
memset(set,0,sizeof(set));
for(i=0;i<m;i++)
{
scanf("%d%d",&u,&v);
if(set[u]==0)
set[u]=u;
if(set[v]==0)
set[v]=v;
if(find(u)==find(v))
sum++;
hebing(u,v);
}
printf("%d\n",sum);
}

return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: