您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之求二叉树后序遍历和层次遍历

2016-08-01 15:09 260 查看

数据结构实验之求二叉树后序遍历和层次遍历


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历。

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

输出

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列

示例输入

2
abdegcf
dbgeafc
xnliu
lnixu


示例输出

dgebfca
abcdefg
linux
xnuli


提示

 

来源

ma6174

#include<bits/stdc++.h>
using namespace std;
typedef struct BiTNode
{
char data;
struct BiTNode *lchild,*rchild;
}BiTNode ,*BiTree;
char a[100],b[100];
BiTNode *createBiTree(char a[],char b[],int n)
{
BiTree root;
if(n==0) return NULL;
char *p;
root = (BiTNode *)malloc(sizeof(BiTNode ));
if(!root) return NULL;
root->data=a[0];
for(p=b;p!='\0';p++)
{
if(*p==a[0])
break;
}
int t;
t=p-b;
root->lchild = createBiTree(a+1,b,t);
root->rchild = createBiTree(a+t+1,p+1,n-t-1);
return root;
}

void _post(BiTree T)
{
if(T)
{
_post(T->lchild);
_post(T->rchild);
cout<<T->data;
}
}

void traverse(BiTree T)
{
queue<BiTree > q;
BiTree p=NULL;
if(T)
{
q.push(T);
}
while(!q.empty())
{
p=q.front();
q.pop();
cout<<p->data;
if(p->lchild)
{
q.push(p->lchild);
}
if(p->rchild)
{
q.push(p->rchild);
}
}
}
int main()
{
int n;
BiTree root;
cin>>n;
while(n--)
{
cin>>a>>b;
int len = strlen(a);
root = createBiTree(a,b,len);
_post(root);
cout<<endl;
traverse(root);
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: