您的位置:首页 > 其它

杭电-1856 More is better (树的节点数)

2016-08-01 15:06 363 查看

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 24124    Accepted Submission(s): 8675

[align=left]Problem Description[/align]
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 
[align=left]Input[/align]
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)
 
[align=left]Output[/align]
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 
[align=left]Sample Input[/align]

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

[align=left]Sample Output[/align]

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 
[align=left]Author[/align]
lxlcrystal@TJU
 
[align=left]Source[/align]
HDU 2007 Programming Contest - Final

 
[align=left]Recommend[/align]
lcy   |   We have carefully selected several similar problems for you:  1272 1325 1879 1875 1102 

解题思路:找出所有树中最大的那个树的节点数;
AC代码:
#include<cstdio>
#define max 10000010
int tree[max];
int father[max],count;

int find(int x)
{
int r=x;
int t;
while(r!=tree[r])
r=tree[r];
while(x!=r)//注意压缩路径,否则超时
{
t=tree[x];
tree[x]=r;
x=t;
}
return r;
}

void megre(int a,int b)
{
int fa,fb;
fa=find(a);
fb=find(b);
if(fa!=fb)
{
tree[fa]=fb;
father[fb]+=father[fa];//记录每棵树的节点数
if(father[fb]>count)
count=father[fb];
}
}

int main()
{
int n,i,a,b;
while(scanf("%d",&n)!=EOF)
{
count=1;
for(i=1;i<max;i++)
{
tree[i]=i;
father[i]=1;//注意初始化
}
while(n--)
{
scanf("%d%d",&a,&b);
megre(a,b);
}
printf("%d\n",count);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: