您的位置:首页 > 其它

POJ 2406 Power Strings [KMP+循环节]

2016-08-01 14:00 309 查看
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative
integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last
test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.


Sample Output

1
4
3


Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:一个字符串可以作为某个子串的连续n个组合而成, 说白了就是有循环节。 找到循环节, 用长度/循环节就是答案 , 但是这里需要判断一下, 因为,只有能被整除的才符合这个, 不能被整除的肯定是1 ;

AC代码:#include <stdio.h>
#include <string.h>
int pre[1000010] , len;
char a[1000010];
void getpre()
{
int i = 0 , j = -1 ;
pre[0] = -1;
while(i<len)
{
if(j==-1||a[i]==a[j]) pre[++i] = ++j;
else j = pre[j];
}
}
int main()
{
while(~scanf("%s",a))
{
if(a[0]=='.') break;
len = strlen(a);
getpre();
int cir = len - pre[len];
if(len%cir==0) printf("%d\n",len/cir);
else printf("1\n");
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: