您的位置:首页 > 其它

HDU 1213 How Many Tables(并查集,认识的朋友做一块)

2016-08-01 10:49 477 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24265    Accepted Submission(s): 12128

[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

 

[align=left]Author[/align]
Ignatius.L
 

[align=left]Source[/align]
杭电ACM省赛集训队选拔赛之热身赛

 

题意:

就是简单并查集问题的模板。不多说了。

加一句:

英语水水的我,看到这两句就懵了......





代码:
#include<stdio.h>
#define MYDD 1103

int pre[MYDD];
void init(int x) {
for(int j=1; j<=x; j++)
pre[j]=j;
}

int find(int x) { //递归查找根节点
return x==pre[x]? x:find(pre[x]);
}

void combine(int x,int y) {
int fx=find(x);
int fy=find(y);
if(fx!=fy)
pre[fx]=fy;
}

int main() {
int t;
scanf("%d",&t);
while(t--) {
int n,m;
scanf("%d%d",&n,&m);
init(n);
int a,b;
while(m--) {
scanf("%d%d",&a,&b);
combine(a,b);
}
int ans=0;
for(int j=1; j<=n; j++) {
if(pre[j]==j)
ans++;//查找根接点个数
}
printf("%d\n",ans);
}
return 0;
}

并查集是基础。
***********************************************

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: