您的位置:首页 > 其它

PAT-A 1058. A+B in Hogwarts

2016-07-31 23:23 357 查看
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27


Sample Output:

14.1.28


程序代码:

#include<stdio.h>
int  a[3],b[3],c[3];
int main()
{
scanf("%d.%d.%d",&a[2],&a[1],&a[0]);
scanf("%d.%d.%d",&b[2],&b[1],&b[0]);
int tmp;
c[0]=(a[0]+b[0])%29;
tmp = (a[0]+b[0])/29;
c[1] = (tmp+a[1]+b[1])%17;
tmp = (tmp+a[1]+b[1])/17;
c[2]=(a[2]+b[2]+tmp);
printf("%d.%d.%d",c[2],c[1],c[0]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: