您的位置:首页 > 其它

杭电2035 人见人爱A^B

2016-07-31 21:22 183 查看
求A^B的最后三位数表示的整数。 

说明:A^B的含义是“A的B次方” 

Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。 

Sample Input

2 3
12 6
6789 10000
0 0


Sample Output

8
984
1


#include<stdio.h>
int powermod(int a,int b)
{
int ans=1;
a=a%1000;
while(b)
{
if(b%2)
ans=ans*a%1000;
b/=2;
a=a*a%1000;
}
return ans;
}
int main()
{
int a,b;
while(scanf("%d%d",&a,&b),a||b)
{
printf("%d\n",powermod(a,b));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: