您的位置:首页 > 其它

poj 3261 Milk Patterns(后缀数组)

2016-07-31 17:26 429 查看
题目链接

Milk Patterns

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 13886 Accepted: 6140
Case Time Limit: 2000MS
Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk
quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He
wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K 

Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.
Output

Line 1: One integer, the length of the longest pattern which occurs at least K times
Sample Input
8 2
1
2
3
2
3
2
3
1

Sample Output
4

Source

USACO 2006 December Gold

题意:

求可重叠的k次最长重复子串


题解:

先计算好SA和height数组。然后二分答案。二分的时候,对height进行分组,看存不存在一组的大小大于等于k

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=20000+5;
int s[maxn];

int sa[maxn];
int t1[maxn],t2[maxn],c[maxn];
int rank[maxn],height[maxn];
void build_sa(int s[],int n,int m)
{
int i,j,p,*x=t1,*y=t2;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[i]=s[i]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
for(j=1;j<=n;j<<=1)
{
p=0;
for(i=n-j;i<n;i++)y[p++]=i;
for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
for(i=0;i<m;i++)c[i]=0;
for(i=0;i<n;i++)c[x[y[i]]]++;
for(i=1;i<m;i++)c[i]+=c[i-1];
for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
swap(x,y);
p=1;x[sa[0]]=0;
for(i=1;i<n;i++)
x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
if(p>=n)break;
m=p;
}
}
void getHeight(int s[],int n)
{
int i,j,k=0;
for(i=0;i<=n;i++)rank[sa[i]]=i;
for(i=0;i<n;i++)
{
if(k)k--;
j=sa[rank[i]-1];
while(s[i+k]==s[j+k])k++;
height[rank[i]]=k;
}
}
bool check(int n,int len,int k)  //根据height分类
{
int ans=0;
for(int i=2;i<=n;i++)
{
if(height[i]>=len)
{
ans++;
if(ans+1>=k) return true;//由于height[i]表示的是sa[i]和sa[i-1]的最长公共前缀,所以用ans+1与k比较
}
else ans=0;
}
return false;
}
int main()
{
int n,k;
scanf("%d%d",&n,&k);
int m=0;
for(int i=0;i<n;i++)
{
scanf("%d",&s[i]);
m=max(m,s[i]);
}
s
=0;
build_sa(s,n+1,m+1);
getHeight(s,n);
int ans=0;
int l=0,r=n;
while(l<=r)
{
int mid=(l+r)/2;
if(check(n,mid,k))
{
ans=max(ans,mid);
l=mid+1;
}
else r=mid-1;
}
printf("%d\n",ans);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: