您的位置:首页 > 其它

题目1015:还是A+B

2016-07-31 15:58 218 查看

题目1015:还是A+B

时间限制:1 秒内存限制:32 兆

题目描述:

读入两个小于10000的正整数A和B,计算A+B。需要注意的是:如果A和B的末尾K(不超过8)位数字相同,请直接输出-1。

输入:

测试输入包含若干测试用例,每个测试用例占一行,格式为"A B K",相邻两数字有一个空格间隔。当A和B同时为0时输入结束,相应的结果不要输出。

输出:

对每个测试用例输出1行,即A+B的值或者是-1。

样例输入:

1 2 1

11 21 1

108 8 2

36 64 3

0 0 1

样例输出:

3

-1

-1

100

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;

int main()
{
int a,b,c;
while(scanf("%d%d%d",&a,&b,&c)!=EOF&&a&&b)
{
int n=1;
for(int i=0; i<c; i++)
{
n*=10;
}
int a1=(a%n);
int b1=b%n;
if(a1==b1)
{
printf("-1\n");
}
else
{
cout<<a+b<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: