您的位置:首页 > 其它

poj 3687 Labeling Balls

2016-07-31 10:14 344 查看
Labeling Balls

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13393 Accepted: 3865
Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating
the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest
weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778


提示

题意:

温迪有N个球,范围1~N,质量都不同。将每个球编号:

1.编号唯一。

2.编号a的小球轻于编号b的小球。

最后输出的是从编号1到编号n每个小球的重量,如果存在多组解,输出使最小重量尽量排在前边的那组解。

(大概就这样了)

思路:

反向建图进行拓扑比较好,可以得到最优解。


示例程序

Source Code

Problem: 3687		Code Length: 1333B
Memory: 544K		Time: 63MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <string.h>
int map[200][200],in[200];
int tuposort(int n)
{
int q[200],i,i1,i2;
for(i=n-1;i>=0;i--)			//反向建图这里就需要反向去拓扑
{
for(i1=n-1;i1>=0;i1--)
{
if(in[i1]==0)
{
q[i1]=i+1;                              //需要输出的是重量,所以这里记录的为i
in[i1]=-1;
for(i2=0;n>i2;i2++)
{
if(map[i1][i2]==1)
{
in[i2]--;
}
}
break;
}
}
if(i1==-1)
{
break;
}
}
if(i==-1)
{
printf("%d",q[0]);
for(i=1;n>i;i++)
{
printf(" %d",q[i]);
}
return 1;
}
else
{
return 0;
}
}
int main()
{
int i,i1,t,n,m,v,u;
scanf("%d",&t);
for(i=1;t>=i;i++)
{
memset(in,0,sizeof(in));
memset(map,0,sizeof(map));
scanf("%d %d",&n,&m);
for(i1=1;m>=i1;i1++)
{
scanf("%d %d",&v,&u);
v--;
u--;
if(map[u][v]==0)		//反向建图
{
map[u][v]=1;
in[v]++;
}
}
if(tuposort(n)==1)
{
printf("\n");
}
else
{
printf("-1\n");
}
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: