您的位置:首页 > 其它

poj 2151 Check the difficulty of problems(dp)

2016-07-30 23:47 417 查看
题目链接

题目描述:

Check the difficulty of problems

Time Limit: 2000MS Memory Limit: 65536K

Total Submissions: 6668 Accepted: 2899

Description

Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input

The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.

Sample Input

2 2 2

0.9 0.9

1 0.9

0 0 0

Sample Output

0.972

题意:

ACM比赛中,共M道题,T个队,pij表示第i队解出第j题的概率

问 每队至少解出一题且冠军队至少解出N道题的概率

题解:

设dp[i][j][k]表示第i个队在前j道题中解出k道的概率

则:

dp[i][j][k]=dp[i][j-1][k-1]p[j][k]+dp[i][j-1][k](1-p[j][k]);

先初始化算出dp[i][0][0]和dp[i][j][0];

设s[i][k]表示第i队做出的题小于等于k的概率

则s[i][k]=dp[i][M][0]+dp[i][M][1]+“““+dp[i][M][k];

则每个队至少做出一道题概率为P1=(1-s[1][0])(1-s[2][0])
(1-s[T][0]);

每个队做出的题数都在1~N-1的概率为P2=(s[1][N-1]-s[1][0])*(s[2][N-1]-s[2][0])*
(s[T][N-1]-s[T][0]);

最后的答案就是P1-P2

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=30+5;
const int Maxn=1000+5;
double d[Maxn][maxn][maxn],s[Maxn][maxn],p[Maxn][maxn];
int main()
{
//freopen("in.txt","r",stdin);
int t,n,m;
while(~scanf("%d%d%d",&t,&n,&m))
{
if(t==0&&n==0&&m==0)
break;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=t;j++)
scanf("%lf",&p[i][j]);
}
/*for(int i=1;i<=n;i++)
{
d[i][0][0]=1;
for(int j=1;j<=t;j++)
{
d[i][j][0]=d[i][j-1][0]*(1-p[i][j]);
}
}*/
for(int i=1;i<=n;i++)
{
d[i][0][0]=1;
for(int j=1;j<=t;j++)
d[i][0][j]=0;
d[i][1][0]=1-p[i][1];
for(int j=1;j<=t;j++)
d[i][j][0]=d[i][j-1][0]*(1-p[i][j]);
for(int j=1;j<=t;j++)
{
for(int k=1;k<=j;k++)
{
d[i][j][k]=d[i][j-1][k-1]*p[i][j];
if(j-1>=k)
d[i][j][k]+=d[i][j-1][k]*(1-p[i][j]);
}
}
}
for(int i=1;i<=n;i++)
{
//s[i][0]=d[i][t][0];
/*for(int j=1;j<=t;j++)
s[i][j]=s[i][j-1]+d[i][t][j];*/
for(int j=0;j<=t;j++)
{
s[i][j]=0;
for(int k=0;k<=j;k++)
s[i][j]+=d[i][t][k];
}
}
double p1=1,p2=1;
for(int i=1;i<=n;i++)
{
p1*=(1-s[i][0]);
}
for(int i=1;i<=n;i++)
{
p2*=(s[i][m-1]-s[i][0]);
}
printf("%.3lf\n",p1-p2);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: