您的位置:首页 > 其它

Sum of Consecutive Prime Numbers

2016-07-30 21:27 183 查看
C - Sum of Consecutive Prime Numbers

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Submit

Status

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.

Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2

3

17

41

20

666

12

53

0

Sample Output

1

1

2

3

0

0

1

2

题意为一个数有连续几个奇数相加;采用离线的方法;将所有的素数求出存放在数组里

#include<stdio.h>
#include<iostream>
using namespace std;
const int maxp=2000,n=10000;
int prime[maxp],total=0;
bool isprime(int k)
{
for(int i=0;i<total;i++)
if(k%prime[i]==0)//如果一个数除以比他小的素数余数为零那么这个数不是素数(定理)
return false;
return true;
}
int main()
{
for(int i=2;i<=n;i++)
if(isprime(i))
prime[total++]=i;
prime[total]=n+1;
int m;
cin>>m;
while(m)
{
int ans=0;
for(int i=0;m>=prime[i];i++)//将小于测试数据的数进行枚举
{
int cnt=0;
for(int j=i;j<total&&cnt<m;j++)//求和
cnt+=prime[j];
if(cnt==m)
++ans;
}
cout<<ans<<endl;
cin>>m;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: