您的位置:首页 > 其它

杭电ACM 1002大数相加 两种方法

2016-07-30 18:40 344 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 316067    Accepted Submission(s): 61349

[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 
像大数这一类题目一般都是用 string 来做, 这个题首要把两个字符串用 reverse 倒序过来运算(由于数字运算是从个位,十位 .....)。最后再倒序回来。
注意:1.这里的运算并不是字符间直接运算,而是转化成 int 型在加减运算。
           2.转化成 int 型的两个数运算后可能出现超过 10 ,一定要记得进位。

我的代码:
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int main()
{
string str,s;
string tempstr,temps;
int n;
int temp;
bool flag;
while(cin>>n)
{
flag = false;
for (int i = 1; i <= n; i++)
{
cin>>str>>s;
tempstr = str;
temps = s;
reverse(str.begin(),str.end());
reverse(s.begin(),s.end());
if(str.length() > s.length())
{
for (int i = 0; i < s.length(); i++)
{
temp = (str[i] - '0') + (s[i] - '0');
if(temp >= 10){str[i] = temp % 10 + '0'; str[i + 1] += 1;}    //实现进位
else str[i] = temp + '0';
}
reverse(str.begin(),str.end());
if(flag)cout<<endl;
cout<<"Case "<<i<<":"<<endl;
cout<<tempstr<<" + "<<temps<<" = "<<str<<endl;
flag = true;
}
else
{
for (int i = 0; i < str.length(); i++)
{
temp = (str[i] - '0') + (s[i] - '0');
if(temp >= 10){s[i] = temp % 10 + '0'; s[i + 1] += 1;}
else s[i] = temp + '0';
}
if(flag)cout<<endl;
reverse(s.begin(),s.end());   //要注意倒序回来
cout<<"Case "<<i<<":"<<endl;
cout<<tempstr<<" + "<<temps<<" = "<<s<<endl;
flag = true;
}
}
}
return 0;
}


老师讲的方法,但不太记的了,加了点自己的想法。

老师的方法比我简单多了。
#include<iostream>
#include<string>
using namespace std;
char add(char temps,char tempstr,int &tempaddc)
{
int temp;
temp = (temps - '0') + (tempstr - '0') + tempaddc; //实现进位。
tempaddc = temp / 10; // 算出进位数
return temp % 10 + '0';
}
int main()
{
string str,s;
int tempaddc;
char c;
int n,lenstr,lens;
while(cin>>n)
{
while(n--)
{
cin>>str>>s;
tempaddc = 0;
c = '0';
if(s.length() > str.length())swap(s,str);
lenstr = str.length();
lens = s.length();
lens--;
lenstr--;
while (lenstr >= 0)
{
if(lens < 0) str[lenstr] = add(c,str[lenstr],tempaddc); //字符串长度较长部分的计算
else
{
str[lenstr] = add(s[lens],str[lenstr],tempaddc);
lens--;
}
lenstr--;
}
cout<<str<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: