您的位置:首页 > 其它

杭电OJ1212-Big Number

2016-07-30 15:15 381 查看


Big Number

Problem Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

 

Output

For each test case, you have to ouput the result of A mod B.

 

Sample Input

2 3
12 7
152455856554521 3250

 

Sample Output

2
5
1521

 

Author

Ignatius.L

 

Source

杭电ACM省赛集训队选拔赛之热身赛

 

Recommend

Eddy

 
     在做题之前,先了解这样一些结论:
A*B % C = (A%C * B%C)%C

(A+B)%C = (A%C + B%C)%C

如 532 mod 7 =(500%7+30%7+2%7)%7;
当然还有a*b mod c=(a mod c+b mod c)mod c;
如35 mod 3=((5%3)*(7%3))%3
   有了这一些结论,题目就好做了!
   代码如下:
#include<iostream>
#include<string.h>
using namespace std;
const int MAX=100010;

int main()
{
char str[MAX];
int s,len,sum;
while(scanf("%s%d",str,&s)!=EOF)
{
len=strlen(str);
sum=0;
for(int i=0;i<len;i++)
sum=(sum*10+(str[i]-'0')%s)%s;
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: