您的位置:首页 > 其它

种类并查集,TOJ(1706)

2016-07-30 14:54 417 查看
题目链接:http://acm.tju.edu.cn/toj/showp1706.html

很类似Poj的一道帮派的问题,记得找到的可疑的关系,不要将集合刷新就可以了。

1706. A Bug's LifeTime Limit: 5.0 Seconds Memory Limit: 65536K
Total Runs: 1190 Accepted Runs: 360 Multiple test
files

Background
Professor Hopper is researching the sexual behavior of a rare species of
bugs. He assumes that they feature two different genders and that they only
interact with bugs of the opposite gender. In his experiment, individual bugs
and their interactions were easy to identify, because numbers were printed on
their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his
assumption of two genders with no homosexual bugs or if it contains some bug
interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario
starts with one line giving the number of bugs (at least one, and up to 2000)
and the number of interactions (up to 1000000) separated by a single space. In
the following lines, each interaction is given in the form of two distinct bug
numbers separated by a single space. Bugs are numbered consecutively starting
from one.

Output
The output for every scenario is a line containing "Scenario #i:", where i is
the number of the scenario starting at 1, followed by one line saying either "No
suspicious bugs found!" if the experiment is consistent with his assumption
about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor
Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4


Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


Hint
Huge input,scanf is recommended.

Source: TUD Programming
Contest 2005

#include <stdio.h>

int father[2010];
int kind[2010];

int Find_Set(int x)
{
if(x!=father[x])
{
int tmp = father[x];
father[x] = Find_Set(father[x]);
kind[x] = (kind[x]+kind[tmp])%2;
}
return father[x];
}

int main()
{
int t;
int cases=1;
scanf("%d",&t);
while(t--)
{

int n,m;
scanf("%d%d",&n,&m);

for(int i=1;i<=n;i++)
{
father[i] = i;
kind[i] = 0;
}
bool flag = true;
while(m--)
{
int x,y;
scanf("%d%d",&x,&y);

int fx,fy;
fx = Find_Set(x);
fy = Find_Set(y);
if(fx!=fy)
{
father[fy] = fx;
kind[fy] = (kind[x]-kind[y]+1)%2;
}
else
{
if(kind[x]==kind[y])
flag = false;
}
}
if(flag)
printf("Scenario #%d:\nNo suspicious bugs found!\n\n",cases++);
else printf("Scenario #%d:\nSuspicious bugs found!\n\n",cases++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: