您的位置:首页 > 其它

BestCoder Round #84 1002 Bellovin

2016-07-30 11:39 363 查看
[align=left]Problem Description[/align]
Peter has a sequence a1,a2,...,an
and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn),
where fi
is the length of the longest increasing subsequence ending with
ai.

Peter would like to find another sequence b1,b2,...,bn
in such a manner that F(a1,a2,...,an)
equals to F(b1,b2,...,bn).
Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an
is lexicographically smaller than sequence b1,b2,...,bn,
if there is such number i
from 1
to n,
that ak=bk
for 1≤k<i
and ai<bi.
 

[align=left]Input[/align]
There are multiple test cases. The first line of input contains an integer
T,
indicating the number of test cases. For each test case:

The first contains an integer n
(1≤n≤100000)
-- the length of the sequence. The second line contains
n
integers a1,a2,...,an
(1≤ai≤109).
 

[align=left]Output[/align]
For each test case, output
n
integers b1,b2,...,bn
(1≤bi≤109)
denoting the lexicographically smallest sequence.

 

[align=left]Sample Input[/align]

3
1
10
5
5 4 3 2 1
3
1 3 5

 

[align=left]Sample Output[/align]

1
1 1 1 1 1
1 2 3

题意: 给一个序列,让换成另一个序列,满足每一位都和原序列的最长上升子序列位数相同,其实就是求每一位的最长上升子序列个数;不能用DP,用nlog(n),不然超时;

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

int dp[100000 + 5];
int b[100000 + 5];

int main()
{
int t;
cin>>t;
while(t--)
{
int n, temp;
cin>>n;
dp[0] = 0;
b[0] = 0;
for(int i = 1, j = 0; i <= n; i++)
{
cin>>temp;
if(temp>dp[j]) //大于最后一位数直接放最后;
{
dp[++j] = temp;
b[i] = j;
}
else
{
int add = lower_bound(dp+1,dp+j+1,temp)-dp; //否则查找到然后替换前面的
dp[add] = temp;
b[i] = add;
}
}
cout<<b[1];
for(int i = 2; i <= n; i++)
cout<<" "<<b[i];
cout<<endl;

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: