您的位置:首页 > 其它

hdu 5775 Bubble Sort

2016-07-30 10:57 405 查看
Problem Description

P is a permutation of the integers from 1 to N(index starting from 1).

Here is the code of Bubble Sort in C++.
for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;


After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

 

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits

T <= 20

1 <= N <= 100000

N is larger than 10000 in only one case. 

 

Output

For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

 

Sample Input

2
3
3 1 2
3
1 2 3

 

Sample Output

Case #1: 1 1 2
Case #2: 0 0 0

HintIn first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

开始一直理解错题意,有的树状数组,有的线段树,反正当时我都不会。
我又想用递归写,结果也没写出来,
最后在网上看看别人代码,整理一下。
思路:
一个数的最左下表=min(初始,目标);
一个数的最右下标=初始+右边比他小的数个数;
用树状数组维护一下。
//n&n-1 清除n最右边的1
//n&-n取得n最右边的1
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#define maxn 100010

using namespace std;

int T,n,cas;
int num[maxn],ans[maxn],f[maxn];
int lowbit(int x){ //取得x二进制形式下最右边的1
return x&(-x);
}
void update(int x){
while(x<=n){
f[x]++;
x+=lowbit(x);
}
}
int get_sum(int x){
int t=0;
while(x!=0){
t+=f[x];
x-=lowbit(x);
}
return t;
}
int main(){
scanf("%d",&T);
int c=0;
while(T--){
memset(f,0,sizeof(f));
scanf("%d",&n);
for(int i=1;i<=n;i++) scanf("%d",&num[i]);
int cnt=0,l=0,r=0,s=0,ant=0;
for(int i=1;i<=n;i++){
update(num[i]);
s=i-get_sum(num[i]);
ant=num[i]+s-i;
l=min(i,num[i]);
r=max(i,i+ant);
ans[num[i]]=abs(r-l);
}
printf("Case #%d:",++c);
for(int i=1;i<=n;i++) printf(" %d",ans[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: