您的位置:首页 > 其它

HDU2717 Catch That Cow

2016-07-29 21:13 190 查看

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point
N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point
K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or
X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and
K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17


Sample Output

4


Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int vis[100010];
int n,m;
void bfs()
{
vis
=0;
queue<int>que;
int x,y;
que.push(n);
while(!que.empty())
{
x=que.front();
que.pop();
if(x==m)
return ;
y=x+1;
if(y>=0&&y<=100000&&vis[y]==0)
{
vis[y]=vis[x]+1;
que.push(y);
}
y=x-1;
if(y>=0&&y<=100000&&vis[y]==0)
{
vis[y]=vis[x]+1;
que.push(y);
}
y=x*2;
if(y>=0&&y<100000&&vis[y]==0)
{
vis[y]=vis[x]+1;
que.push(y);
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(vis,0,sizeof(vis));
bfs();
printf("%d\n",vis[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: