您的位置:首页 > 其它

hdu 1564 Play a game (博弈 奇偶规律)

2016-07-29 20:47 513 查看

Play a game

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2322 Accepted Submission(s): 1865

Problem Description

New Year is Coming!

ailyanlu is very happy today! and he is playing a chessboard game with 8600.

The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line.

The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner (“8600” or “ailyanlu”) for each input line except the last zero.

No other characters should be inserted in the output.

Sample Input

2

0

Sample Output

8600

题意:给你一个n∗n的游戏棋盘,一个石头在任意的一个方格内,两个人交替移动石子,石子只能被移动到相邻且没有移动过的格子内,谁不能移动谁输.

思路:格子总会走完的,所以说根据格子数量判断奇偶性就可以了.

ac代码:

/* ***********************************************
Author       : AnICoo1
Created Time : 2016-07-29-20.42 Friday
File Name    : D:\MyCode\2016-7月\2016-7-29.cpp
LANGUAGE     : C++
Copyright  2016 clh All Rights Reserved
************************************************ */
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<set>
#include<map>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 1010000
#define LL long long
#define ll __int64
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
#define eps 1e-8
using namespace std;
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
ll powmod(ll a,ll b,ll MOD){ll ans=1;while(b){if(b%2)ans=ans*a%MOD;a=a*a%MOD;b/=2;}return ans;}
double dpow(double a,ll b){double ans=1.0;while(b){if(b%2)ans=ans*a;a=a*a;b/=2;}return ans;}
//head
int main()
{
int n;
while(scanf("%d",&n)!=EOF,n)
{
int x=n*n;
if(n%2)
printf("ailyanlu\n");
else
printf("8600\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: