您的位置:首页 > 其它

POJ2488 A Knight's Journey

2016-07-29 18:46 323 查看

 

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany

 

要求字典序最小,那么暴力枚举起点然后DFS就行。沿途存下路径,最后转化成字符输出。

 

/**/
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int mxn=125;
int vis[mxn][mxn];
bool flag;
int mx[9]={0,-2,-2,-1,-1,1,1,2,2},
my[9]={0,-1,1,-2,2,-2,2,-1,1};
int n,m;
int qx[mxn],qy[mxn];
void dfs(int x,int y,int cnt){
qx[cnt]=x;qy[cnt]=y;
vis[x][y]=1;
if(cnt==m*n){
flag=1;
return;
}
for(int i=1;i<=8;i++){
int nx=mx[i]+x;
int ny=my[i]+y;
if(nx<1 || nx>m || ny<1 || ny>n)continue;
if(vis[nx][ny])continue;
dfs(nx,ny,cnt+1);
if(flag)return;
}
vis[x][y]=0;
return;
}
int main(){
int T;
scanf("%d",&T);
int cas=0;
for(cas=1;cas<=T;cas++){
memset(vis,0,sizeof vis);
flag=0;
int i,j;
scanf("%d%d",&n,&m);
for(i=1;i<=m;i++){
if(flag)break;
for(j=1;j<=n;j++){
dfs(i,j,1);
if(flag)break;
}
}
printf("Scenario #%d:\n",cas);
if(flag){
for(i=1;i<=n*m;i++)printf("%c%d",qx[i]+'A'-1,qy[i]);
}
else printf("impossible");
printf("\n");
if(cas<T)printf("\n");
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: