您的位置:首页 > 产品设计 > UI/UE

Building a Space Station--最小生成树

2016-07-29 15:40 525 查看
Building a Space Station

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7427 Accepted: 3601
Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 

The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is
quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or
(3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least
three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with
the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form
a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 



x1 y1 z1 r1 

x2 y2 z2 r2 

... 

xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after
the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input
3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output
20.000
0.000
73.834


题目链接:http://poj.org/problem?id=2031

最近刷题越来越难的说,此题是裸地最小生成树,题目大意大概是说你是空间站的一员,空间站有好多圆形的房子,给你每一个房子的坐标,三维的,然后给你房子的半径,让你求链接所有房子的走廊的长度是多少,先求出左右的房子间彼此的距离,然后就是板子了。。。

注意在poj上用G++交题时,因为编译器的问题,所以double要用%.f而不是%.3lf,否则会wa。。已以身试法

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
double x,y,z;
double r;
}xin[2000];
double a[2000][2000];
double lowc[2000];
int vis[2000];
int n;
void juli(int i,int j)
{
double h=sqrt((xin[i].x-xin[j].x)*(xin[i].x-xin[j].x)+(xin[i].y-xin[j].y)*(xin[i].y-xin[j].y)+(xin[i].z-xin[j].z)*(xin[i].z-xin[j].z))-xin[i].r-xin[j].r;//求距离
if(h<a[i][j])
a[i][j]=a[j][i]=h;
if(h<0)
a[i][j]=a[j][i]=0;
}
double prim()
{
memset(vis,0,sizeof(vis));
int i,j;
for(i=0;i<n;i++)
{
lowc[i]=a[0][i];
}
vis[0]=1;
double minc;
double res=0;
int p;
for(i=1;i<n;i++)
{
minc=inf,p=-1;
for(j=0;j<n;j++)
{
if(lowc[j]<minc&&!vis[j])
{
minc=lowc[j];
p=j;
}
}
if(p==-1)
return -1;
res+=minc;
vis[p]=1;
for(j=0;j<n;j++)
{
if(lowc[j]>a[p][j]&&!vis[j])
{
lowc[j]=a[p][j];
}
}
}
return res;
}
int main()
{
int i,j;
while(~scanf("%d",&n)&&n)
{
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
if(i==j)
a[i][j]=1;
else
a[i][j]=inf;
}
}
for(i=0;i<n;i++)
{
scanf("%lf",&xin[i].x);
scanf("%lf",&xin[i].y);
scanf("%lf",&xin[i].z);
scanf("%lf",&xin[i].r);
}
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
juli(i,j);
}
}
double h=prim();
printf("%.3lf\n",h);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: