您的位置:首页 > 其它

杭电-1312 Red and Black(DFS)

2016-07-29 11:48 357 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17542    Accepted Submission(s): 10665

[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

 

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

[align=left]Sample Output[/align]

45
59
6
13

 

[align=left]Source[/align]
Asia 2004, Ehime (Japan), Japan Domestic 

这道题题意很简单,用深搜搜索就行了

AC代码:

#include<stdio.h>
#include<string.h>
int m,n;
int ans;
char a[1100][1100];
int dfs(int x,int y)
{
if(x< 0 || x >= n|| y < 0 ||y>=m)
return 0;
if(a[x][y]=='#')
return 0;
else
{
ans++;
a[x][y]='#';
dfs(x,y+1);
dfs(x+1,y);
dfs(x,y-1);
dfs(x-1,y);
}
return ans;
}
int main()
{
int i,j;
while(scanf("%d%d",&m,&n)!=EOF)
{
ans=0;
if(m==0||n==0)
break;
int fi,fj;
for(i=0;i<n;i++)
{
scanf("%s",a[i]);
}
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
if(a[i][j]=='@')
{
fi=i;
fj=j;
}
}
}
printf("%d\n",dfs(fi,fj));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: