您的位置:首页 > 其它

HDU 1213

2016-07-28 21:34 337 查看
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile

‘#’ - a red tile

‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

….#.

…..#

……

……

……

……

……

@…

.#..#.

11 9

.#………

.#.#######.

.#.#…..#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#…….#.

.#########.

………..

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

.

…@…

.

..#.#..

..#.#..

0 0

Sample Output

45

59

6

13

题意:@表示一个人,问他能踩多少个点点

题解:用dfs深度搜索一哈

#include <cstdio>
#include <cstring>

char map[200][200];
bool list[200][200];
int ka[4][2] = {{1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int row, col, sum, m, n;
void dfs(int row2, int col2)
{
if(row2 < 1 || row2 > m || col2 < 1 || col2 > n || list[row2][col2] || map[row2][col2] == '#')//判断截止的条件
return ;
sum++;
list[row2][col2] = true;//踩过的记录一下,避免再踩
dfs(row2+1, col2);//各种搜索
dfs(row2-1, col2);
dfs(row2, col2+1);
dfs(row2, col2-1);
}
int main()
{
while(scanf("%d%d", &n, &m) != EOF && n || m)
{
for(int i=1; i<=m; i++)
{
getchar();
for(int j=1; j<=n; j++)
{
scanf("%c", &map[i][j]);
if(map[i][j] == '@')
{
row = i, col = j;//记录位置
}
}
}
sum = 0;
dfs(row, col);
memset(list, false, sizeof(list));
printf("%d\n", sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: